10.3.3 Target iOS and MACOS what versions of XCODE are supported

Do we have a definitive list of the version of XCODE and command line tools that can be used to develop for iOS and MACOS

If I have a mac running macOS 10.14: Mojave and one running macOS 10.15: Catalina

What are the versions of XCODE that RAD Studio 10.3.3 requires for each of these to produce working apps?

Parents
  • It's a large topic, but long story short, you should be fine if you install Xcode from the macOS App Store(or update it to the latest version, if it has been installed) on both Mojave and Catalina. This will give you Xcode 11.2.1 with SDK 10.15. Delphi 10.3.3 works just fine with SDK 10.15 (as well as 10.14 and 10.13). Once you've installed the latest Xcode, you can add the latest SDK to Delphi, as you normally do.

    For the avoidance of doubt, you can run and debug apps compiled with the newer SDK versions on older macOS versions. For example, an app compiled with SDK 10.15 can run on Mojave just fine.

    I'm not an expert in iOS, but I believe all of the above applies to iOS as well.

Reply Children
No Data