[Solved] MacOS64: No icon when submitting to store

Has anyone tried to send a MacOS64 app to the Apple App Store yet?

Using Application Loader inside Xcode 10.3 on Mojave 10.14.6.

When I upload an app to submit it to the store no icon is displayed. The pkg file uploads just fine however checking inside "App Store Connect" (former iTunes connect) the uploaded build also does not have an icon. Apple's shows a question-mark instead.

Any idea what I'm doing wrong?

Also tried the same with an empty-form-app and using Embarcadero's default app icons. Same thing: icon is not showing within Application Loader...

I was sooo glad seeing that there's finally 64bit support for Mac...

Please help! 

Thanks!

  • Did some more digging. I don't think Application Loader is the problem.

    * When I upload an ipa-package (for iOS) then the logo is shown inside the Application Loader.

    * When I upload a pkg-package (for MacOS) then no logo is shown. (see picture)

    As said in my original post, if I proceed to send the pkg-package to Apple no icon is shown inside App Store connect which probably means that the pkg truly does not contain an icon.

    Do you have the same issue or am I the only one with this?

    Do you know who to contact (or where to send this) to report this issue and find someone to help me?

  • Good news.

    Our app is now available on the Mac Store and Apple finally approved the MacOS app.

     

    Long story short, for whomever runs into the same issue and has the same question... Just continue while not seeing an icon and submit the app.

    Tell to have Apple review the app and after that process the icon magically appears from then on, also inside Application Loader.

     

    Thus, the icns file was perfectly fine. Somehow this is/was at Apple's end, and in the end, nothing to worry about.

     

    Hope this helps!