Can a standalone application communicate with itself on a different device over app tethering?

I have an application that I want to send string data from an instance on one device to an instance of the same app on another device. I can't seem to get the two instances on separate devices to work. If I run multiple instances of the app on the same Windows 10 machine, the app functions perfectly. But, when running the app on two different Windows 10 machines both on the same network, it doesn't work.

I tried adjusting the Windows Firewall settings on both machines to allow TCP and UDP traffic for the app (inbound and outbound), but it still doesn't work. I tried it from an iPhone to Windows, iPhone to Android, iPhone to macOS, etc. on the same network and still nothing. It only works when the app is running multiple times on the same machine.

Anyone conquered this yet and can share how? Do I need two app tethering profiles, one for 'Master' and one for 'Remote' each with it's own Resource?

Most sample configurations have two different apps. I want one app that will send a string to all connected instances of itself that are running on another device within the same network.

Thanks in advance for any advice.

No Data
  • Hi,

    The best I reached is get connection between a Windows and Android, on both directions, but not with iOS. I didn't test with another Windows nor macOS because is not part of my objetive. What I want is communicate between Windows, Android and iOS.

    I learned that Firewall configuration is critical and not always work as expected, for example McAfee simply block the communication and the configurations does not work. I did deactivate it, open the application and the reactivate it.

    On my case it was absolutely imposible to connected any of the AppTethering sample applications that came with RAD Studio. I don't know if there is something missing, wrong, or a bug (I already opened a bug report but without any answer yet: In this situation I have to forget this project: really bad thing.

    I hope that someone from Embarcadero would comment soon here or through this bug report if this is a bug or not and how to solve it.

    Best regards,