how to use jedi jcl/jvcl package with 10.4 ? it does not compile

even after adding special section to jedi.inc - about new compiler version - install.bat does not compile

expressing two errors:

<jedi path>\jcl\source\common\JclAbstractContainers.pas(2554) Error: E2010 Incompatible types: 'TObject' and 'T'
<jedi path>\jcl\source\common\JclArrayLists.pas(2691) Fatal: F2063 Could not compile used unit 'JclAbstractContainers.pas'

someone which managed this?

jedi package is not available thru getit also