Apple released Mac OS X El Capitan today.

With Delphi, C++Builder and RAD Studio 10 Seattle, we provide support for building OS X applications that run on OS X 10.10 (Yosemite) or 10.9 (Mavericks). We also provide support for building applications that run on iOS 9 using the iOS 9 SDK, or on iOS 7, 8 and iOS 9 using the iOS 8 SDK.
 
This PAServer Hotfix that we released for Delphi, C++Builder and RAD Studio 10 today provides fixes for:

  • building OS X 10.11 (El Capitan) applications with Delphi, C++Builder and RAD Studio 10 Seattle
  • building iOS applications that run on iOS 7, iOS 8 and iOS 9 using the iOS 9 SDK with Delphi, C++Builder and RAD Studio 10 Seattle. This allows you to use the latest iOS SDK to target older versions of iOS.

You can download the hotfix here: http://cc.embarcadero.com/item/30398

Please view the included readme for step-by-step install and post install instructions.

  • Hi, Sarina. I've a one small question. In Delphi XE 10.1 Berlin - hotfix is available for compiling applications in release mode. Is there something similar for the Delphi XE 10 Seatle?When I run an app for a device with Mac OSX or iOS. No problem, but for iOS simulator. I can only compile and run the application in DEBUG mode. Making the final release - for iOS the simulator ends with an error: Unable to launch process im '192.168.1.200' using the parameters from the 'macBook' profile. How can I solve this problem?
  • Hi Sarina, I have a question that this PAserver hot fix is for Seatle 10 and Seatle 10 update 1 both ? Please send me information about because I did the PAServer hot fix on Seatle 10 update 1 and : 1. I can compile, build, deploy on the device 2. when I build ad hoc release the program don't work on IPhone 4 with IOS 9.2. best regards Marcin
  • Hi Graham, The issue you mentioned is not related to the PAServer hotfix. Looking at your message, it sounds like your .app name is missing. I would recommend doing the following: a. Create a new simple Multi-Device Project, and hit Run with/without debugging, and see if you can still reproduce the issue b. If you cannot reproduce this problem, I would recommend the following: 1. Shut down the IDE, delete the project5.deployproj file (located in the same location where project5.dproj is located), launch the IDE, open Project5, and run with/without debugging again. Can you reproduce the issue now? 2. If the problem still happens, you can compare project5.dproj with the new project created in step a) above to see if you find any differences. Regards, Sarina
  • Hello Sarina, I installed the PAServer hot fix as described in the readme. How could I verify that the hot fix is effectively installed ? Is there a change in version number I can check ? I'm encountering many problems migrating an application that worked fine on iOS 8.4 (developed with XE8) to iOS9 and Delphi 10. It shows the splash screen on my iPhone but it freeze just after it. Thank you, Davide
  • Graham thanks for the feedback. I won't install it. I have already deployed an iOS 9 app to the App store from EL Capitan and Seattle 10 without it.
  • Ok, I've just tried to roll back to PAServer 17 using the installer which came with Delphi Seattle and now I get the following errors in my build output log when I try and deploy the app to an iPhone... Build started 10/1/2015 1:10:12 PM. __________________________________________________ Project "C:\Users\Graham\Documents\Embarcadero\Studio\Projects\Project5.dproj" (Deploy target(s)): Target _CleanRemoteDir: Cleaning Remote Directory: d:\program files (x86)\embarcadero\studio\17.0\bin\paclient.exe -u8 --Clean=",C:\Users\Graham\Documents\Embarcadero\Studio\Projects\Project5._@emb_.tmp" -u8 --Clean=".dSYM,C:\Users\Graham\Documents\Embarcadero\Studio\Projects\Project5._@emb_.tmp" ios Platform Assistant Client Version 8.0.1.43 Copyright (c) 2010-2015 Embarcadero Technologies, Inc. Connecting to 192.168.1.182 on port 64211... Deleting file(s)... d:\program files (x86)\embarcadero\studio\17.0\bin\CodeGear.Deployment.targets(227,5): error : Error: E0004 File does not exist: C:\Users\Graham\Documents\Embarcadero\Studio\Projects\Project5._@emb_.tmp Total file(s) deleted: 0 file(s) 0 dir(s) Done building target "_CleanRemoteDir" in project "Project5.dproj" -- FAILED. Done building project "Project5.dproj" -- FAILED. Build FAILED. d:\program files (x86)\embarcadero\studio\17.0\bin\CodeGear.Deployment.targets(227,5): error : Error: E0004 File does not exist: C:\Users\Graham\Documents\Embarcadero\Studio\Projects\Project5._@emb_.tmp 0 Warning(s) 1 Error(s) Time Elapsed 00:00:00.04 Really need a solution to this - I installed the update to fix the issue of deploying to iOS 7/8 from Seattle but it has now broken everything. Very frustrating.
  • Hi Sarina, I'm afraid the HotFix has not worked and has left my PAServer broken. A blank project for iOS compiles fine, but as soon as I try to run it, I get a PAClient error "[PAClient Error] Error: E0004 File does not exist: C:\Users\Graham\Documents\Embarcadero\Studio\Projects\Project5._@emb_.tmp" And a screen appears saying "Troubleshooting: Cannot Connect to the Mac" I've followed the steps in the readme and deleted, recreated and updated the profile/local cache within Delphi 10. Any ideas how I can get the PAServer to function? Would it not be possible to package the hotfix as an installer? I hope there is a solution for this as I'm a bit stuck now not able to deploy apps. Kind regards, Graham Murt