[Update: With the 10.3 Carnival Beta, you're now able to target the Google Play Store to meet the new API level requirement. If you're a customer active on Update Subscription, contact your sales representative if you haven't received an invite to join the 10.3 NDA Beta.]
If you’re not currently building for Android and your team doesn’t have plans to target Android in the near future, you can disregard this upcoming Google Play Store requirement.
Do you know how you will meet the new Google Play requirements that apps support at least Android 8.0 (API level 26)? Here are the critical dates you need to know:
  • AUGUST 1, 2018.  All new apps must target Android API level 26
  • NOVEMBER 1, 2018. All app updates for existing apps must target Android API level 26.
We’ve gotten a number of questions from our customers on this and wanted to share how you can address these new requirements. There are at least two solutions.

 

Option 1: Get the 10.3 Beta Release including support for Android API level 26

The change to support Android API level 26 requires significant work, and is not possible in a 10.2 update. We plan to deliver full support for Android API level 26 in the next major release of RAD Studio, 10.3. While this release will take some more time, we understand that some customers require a solution soon. We will invite all customers on active Update Subscription to join our upcoming 10.3 Beta (under NDA). More details on the Beta and how to sign up will be shared in the coming weeks over email - check your inbox.
The 10.3 beta will allow you to target Android API level 26. Although the usual beta restrictions do not allow for building and deploying production apps, this beta will have a special EULA provision allowing you to deploy (production) Android apps to the Google Play Store.
Being able to participate in our Beta program is one of the great benefits of Update Subscription. You can check how many days you have remaining on your Update Subscription using the License Manager.

 

Option 2: Using 10.2.3

In lieu of using the 10.3 beta to deliver Android API level 26 ready apps, another option is to follow Embarcadero MVP Dave Nottage’s excellent blog post on how to target Android API Level 26 with Delphi, C++Builder and RAD Studio 10.2.3 Tokyo: http://delphiworlds.com/2018/06/targeting-android-8-and-higher-continued/
 
Note: Features discussed above are not committed until completed and GA released.
 
Anonymous