RAD Studio 10.4 patch 2 was released yesterday, but installing has some manual steps. Here's how to do it.

10.4 Patch 2 (see Marco's blog post) solves 51 issues, in areas including debugging instability, Delphi code completion, the IDE, the Delphi compiler, C++ Android exception handling, and more. Unlike normal patches, it requires some manual installation steps -- installing the patch from GetIt only downloads, it does not install. Here's a visual guide on the full patch #2 installation process.

Installing 10.4 patch 2 took me three and a half minutes (3:38, so eight seconds more, if you're counting!)

Video Guide

Step By Step

1. Download the patch through GetIt

Downloading... this took 1:20 for me but will depend on your internet speed.


2. Run the patch

I do this from a separate command prompt, because running the batch file from Explorer does not prompt me for UAC and run the installer. Note my paths will be different to yours, because I use a VM (you're likely to have your Documents folder on C:, not on Z: as in these screenshots.)


If you want to verify the patch installed correctly, open your RAD Studio installation \bin folder, and located getit270.bpl. It should have a modified data of July 2020, while most other files are May.

Reduce development time and get to market faster with RAD Studio, Delphi, or C++Builder. Design. Code. Compile. Deploy.

Start Free Trial   Free Delphi Community Edition   Free C++Builder Community Edition   Upgrade Today  

No Data
  • Would love to know how this works for you: I've tried to install 10.4 Patch 2 through Get-it but after downloading, it says the file is corrupt. I've tried manually downloading from the Embarcadero portal and when extracting it also says it's corrupt (and the same MD5 hash is displayed as in Get-it - which is different to the expected hash displayed on the portal). I've tried manually downloading in different browsers with the browser's built-in downloader as well with a 3rd party download manager - all download the exact same corrupt file (oh, and I've tried my work and home computers). I've messaged Embarcadero on Twitter, but no reply - I guess it's just a "post-only" account.  I've logged it with support and am waiting for someone to get back to me.  The MD5 is supposed to be bd1d0c027975d6aca88aea1fa5992b88 (according to the portal) but Get-It shows the MD5 as b062a9cdc3af991c8303d83412428a63 (which is identical to when I check the manually-downloaded zip file, too).