Issue with SQLcm after upgrading OS

I recently upgraded the OS on my SQLcm server to 2019.  I currently have two registered servers and initially was having trouble with  IderaCM saying "No recent heartbeat" on both.  I then added the IderaCM applications through the firewall on the server and it allowed the 2nd one to start responding.  

HOWEVER, I have tried updating the agent on both (after changing an audit setting) and the application seems to hang when I do this.  The cursor just spins and I have to restart IderaCM.   Also, I just tried to restart the SQLcompliance Agent on the first server and now it just says "stopping" (the server that says No heartbeat).   On the second server, the service restarts fine. 

Does anyone have any ideas how to resolve?   If I uninstall and try reinstalling the registered server I think I will lose all of my audit settings.


  • So on the server that is unable to connect, I just uninstalled the Collection Service.  I was then hoping I could go to the IderaCM server and deploy the Agent but it is grayed out.  

Reply Children
No Data