KB: How to install PowerShell 3 or later (a prerequisite of PowerShell Plus)

The Tech Specs of PowerShell Plus list Microsoft PowerShell 3.0 or higher as a prerequisite.

Microsoft Windows 8 and later and Microsoft Windows Server 2012 and later include Windows PowerShell 3.0 and all of its prerequisites, per Microsoft’s web page for installing Windows PowerShell.

The latest version of PowerShell is 5.0, and it is included with Windows 10 and Windows Server 2016, per Microsoft’s web page for installing Windows Management Framework 5.0 (of which PowerShell 5.0 is a component).

So, the prospect should install the compatible PowerShell version depending on the Windows version that they are using, per Microsoft’s instructions.

For Windows Vista and XP, and Windows Server before 2008 R2 SP1: PowerShell 3 and thus PowerShell Plus are not available. The Tech Specs of PowerShell Plus also mention this.