Unable to specify MySQL server name

I just downloaded the new MySQL Query Explorer. When trying to connect, the connect button will gray out if you type a period. I have to include the name of the server and our domain (e.g. servername.domain.com). Just specifying the name will not connect due to the server being on the DMZ.

Is this a bug or by design? If by design, why?

Thanks.

  • Same issue here. We manage servers inside a data centre – the ONLY way to get access is via name or IP. As soon as we type in a period the Connect button is greyed out.

    Also, why does it ask “Do you want to allow the following program to make changes to this computer?” whenever it starts up?

  • This is for security. When you type in a user name and enter a password the connect button should be enabled again. Have you tried to enter the server/IP and the proper user name and password and still don’t get the connect button to enable?

  • Hi, David.

    I have specified a username and password, but the button will not activate; unless, I remove the periods. I even tried erasing all information on the connect screen and re-entering it, but to no avail. I believe this to be a bug.

  • Yes you have identified a limitation in the free tool when connecting to servers in a DMZ. Using the full realized name i.e. server.domain.com is not supported. You may be able to connect using the IP address and periods are accepted, but again if behind a DMZ you can experience problems like you have described. The connect button activates when it can resolve the IP and in this case it looks like it cannot. I apologize this tool is not meeting your needs. I have made a note to look at this capability in more details for a future maintenance update.

  • I was able to get it to connect via the IP address. Before I created this topic, I did try to type in the IP address, but when I entered the first octet and the period, I saw the connect button disable and so I quit at that point. I should have entered the entire IP address. That’s my bad. This will at least let me try the tool out.

    I understand limiting features in the free tool, but, IMO, limiting the ability to specify a server to connect to via its name and domain seems a little pointless to me.

    Anyways, thanks for your help, David.

  • Glad you got it to connect. You make a good point and we will look at that.

    Best Regards

  • I am trying to connect to an AWS MySQL instance and using an IP address instead of a friendly hostname or a CNAME is cumbersome for the cloud. I do not know what the security issue since you need a valid username/password to login.

    If this free tool is something you want people to use you need to allow them to connect to any host they specify.