SQL WA 1.6.5 - Dashboard Service Requirement: PostgreSQL

Does PostgreSQL 9.6.10 need to be installed?

If yes, can 9.6.13 (current minor version) or latest version 11.3 be installed, or does it have to be specifically 9.6.10?

Is PostgreSQL the repository?

If yes, why doesn't SQL Workload Analysis allow the use of SQL Server as repository?