Data Architect Keeps Crashing

I opened a ticket with support several months ago about this and after a couple weeks of going back and forth, they came back and said they couldn't figure anything out and that was the end of that. Here is the situation. After upgrading to ERDA 19.0, it started crashing on me whenever I edit an object in the model. I can update the model; I just can't bring up any of the editor dialog windows. This happens on an existing model but also happens when I create a new model. It happens every time on every model, regardless of whether it's a new model or an existing model, regardless of whether I am connected to the repository or not. For instance, I create a new model, add an entity to it, adding columns as part of that process. But when I double-click (or right-click and select Edit) on that entity to edit it, it immediately crashes with no warning. The same thing happens with relationships and BDOs. It does not crash when trying to edit a Title Box or other shapes object. But I can save the model after adding entities to it. I just can edit any data objects on it. I have tried this with 19.0, 19.1, 19.1.1 and 19.2.1, all with the same effect. I have done a repair on the installs; I have done an uninstall/re-install. I have uninstalled all of the versions and tried to just install one version at a time. I have installed a version on a brand new laptop that had never had any of them installed prior. I get the same results every time. The one thing that has worked is to install it on a virtual desktop and log in to it with my VMWare Horizon Client.

The following Windows Event Viewer details do not seemingly provide any helpful information. Has anyone experienced any issue like this that may have some insight? 

Log Name: Application
Source: Application Error
Date: 9/21/2022 3:59:55 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Faulting application name: ERSTUDIO.exe, version:, time stamp: 0x626a832c
Faulting module name: ERUI64.dll, version:, time stamp: 0x626a7f94
Exception code: 0xc0000005
Fault offset: 0x0000000000a37f34
Faulting process id: 0x10bcd0
Faulting application start time: 0x01d8cdf4abaf847b
Faulting application path: C:\Program Files\IDERA\ERStudio Data Architect 19.2\ERSTUDIO.exe
Faulting module path: C:\Program Files\IDERA\ERStudio Data Architect 19.2\ERUI64.dll
Report Id: 990e4a77-c3a8-433b-93c9-2b81ac31e1bd
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="">">
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<TimeCreated SystemTime="2022-09-21T19:59:55.6129755Z" />
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Security />
<Data>C:\Program Files\IDERA\ERStudio Data Architect 19.2\ERSTUDIO.exe</Data>
<Data>C:\Program Files\IDERA\ERStudio Data Architect 19.2\ERUI64.dll</Data>

  • Hi Larry,

    I'd try to:

    • Exit ER/Studio Data Architect if it is running
    • Open the Registry Editor (regedit.exe)
    • Set a blank value to: HKEY_CURRENT_USER\SOFTWARE\Idera\ER/Studio Data Architect 19.2\Repository\Portal Address
      The path changes with the version you want to test (19.1, 19.2, ...)

      If the value of Portal Address was already empty, this is the end of the test as it isn't updated!
    • Start ER/Studio Data Architect and test again Fingers crossed

    As it is working with old version of ER/Studio Data Architect, this should be related to new features... With no value to Portal Address in the Windows Registry, maybe it changes how the code is executed by ER/Studio Data Architect... (New feature: Glossaries.... even if you connect or not to Team Server, it is worth a try...)



  • I checked and don't actually have an entry in the registry for Portal Address.

  • As it works on a virtual desktop but not on your laptop: do you have the same antivirus in both environments?

  • We have the same antivirus on both, but I believe it is configured a little differently between the two environments. I have checked the protection history on my laptop and don't see any actions blocked at the time of the crashes. However, I am having our security team look into it deeper to see if they can detect anything going on with antivirus. I'll update the post if I find out anything.