Data Lineage Import From Excel Macro

Hi,

I am having trouble with the Data Lineage Import from Excel macro.  It gives the error message (10094) ActiveX Automation: Object var is 'Nothing'.  Has anyone been able to fix this macro?

Thank you.

Parents
  • Having the same problem.  This is in ER Studio 19.1.  Very difficult to trace down where the error is occurring and I really need to be able to do this in order to restore some info that was lost in upgrading to V19 in a couple models.  If anyone has fixed this, please advise

    I debugged this far enough to identify that it is this statement that is failing:

    Set dmml = mdl.DataMovementModelLinks.Item(mdl_name)

    Tried capturing some data points to see what various variables are set to and also tried to just get a Count of DataMovementModelLinks.  The count also fails.  

    The variables are set to:

    mdl = Physical
    mdl_name = LOB_TSD
    tab_name = BILL_LDGR_DTL
    col_name = posting_dt

    And I can see that the LOB_TSD is defined on the Model Data Movement Properties dialog for the Physical model.  I have no idea what is wrong.  

  • Hi,

    I reproduced the issue. I was testing Visual Data Lineage Import from Excel.bas instead of Data Lineage Import from Excel.bas

    You should log a case here: https://idera.secure.force.com/embtsupport/

    The variables are the same for me. It looks like an internal object issue as even the property Count doesn't work.

Reply Children
No Data