Printing these models.

For the life of us we cannot get our model to print out or even converted to a simple .jpeg or .pdf. We do manage to get it partially, but never lined up accordingly and always come out a mess. Multiple pages or a single page where the model is very small and off to one corner. We are trying to eventually get it to print to a plotter we have to hang up in our support section for them to have as a visual aid. We have tried every different option or fit page, 1;1, current zoom, etc.

  • Ensure that your printer/plotter drivers are up to date and that your page sizes are correct.  You may wish to experiment with a user defined page scale to see if you can get it to print on a few pages as a test.  You can drag a page border in the print preview dialog to resize the user defined scale.  Please contact support so they can walk through the steps you are taking.

  • We had the same problem with a plotter, below is the information we documented to make the images print better, don't know if they will work for you...

    View – Diagram and Object Display Option –check Show Page Boundaries.  This will enable the page boundaries on the Diagram.

    Minimize the data model

    Select the complete data model and move it to the top left corner. Keep adjusting the tables  and the entire data model  until whole diagram comes under one page or two pages , but not in between the pages

    Go to print - select printer at the bottom, select landscape or portrait as per need.

    Go to properties –Select the appropriate document size or create a custom option select the appropriate width and length of the paper that you might need and name it .

    Then select your custom option in the document Size

    Adjust the Zoom size in the Data model or create a User Defined scale to fit into the window.

    If the data model cannot be adjusted to fit into one paper, either adjust the document size in the printer properties or reduce Zoom level or User defined scale.

    If you want to maintain the same zoom level the data model gets printed in 2 or 3 sheets and then we tape the data model.

    Make the adjustment to a point where the user has a font big enough to read the table and column names.

    Print the data model.

  • I'm having similar issues printing to PDF (using the Adobe PDF printer) in version 18.2 so I contacted support. It is a large database (476 tables, 9,211 columns). After a few back and forth emails, this is what I was told.

    "Basically, in regards to the printing issue you have encountered,

     ER/Studio product team is aware that at some instances it is difficult to print out large models.

    That is why there are plans by development team to completely re-do the way printing is done in ER/Studio DA.

     However, such change would require a new version release. So, development is aware of the printing challenges that large models bring.

     At the moment there is not many options except to try playing with different zoom options and/or trying to break up models into sub-models."

    I started the model as three pages to make it more readable, but had horrible results printing to PDF (ARCH E size) so I jammed everything together on one page and finally had some success after setting the zoom to 40%, but it's not centered on the PDF. Everything is shifted left. This isn't ideal, but I had a deadline and had to get it out. It was very frustrating to spend so much time trying to get it to print correctly.