upgrading PHP and Apache on uptime 7.6

has anyone manually upgraded PHP and Apache on uptime 7.6?
Our security monitoring has identified vulnerabilities with PHP 5.4.45 and openSSL 1.01p. Ive seen the upgrade document here and the windows downloads here but the windows x64 download is currently shown as experimental so I don’t want to do it without more feedback.

With uptime 7.7 coming out soon I’m wondering if I should just wait since hopefully it fixes these vulnerabilities.

James