Propagating Enterprise Data Dictionary changes in the repository

I have just upgraded to Team Server 17.0. I am now trying to maximize our use of the features of the ER/Studio suite of tools to assist us in our efforts to gain traction in our data governance program. I am trying right now to establish an enterprise data dictionary to use across our various models. I have created a dm1 file with our enterprise data dictionary and have successfully created that as the Enterprise Data Dictionary in our repository. However, none of the items in my EDD (e.g. attachments, domains, etc.) show up under the EDD in my repository. In particular, right now I am trying to create custom attributes using the attachment types I created in my EDD. However, they don't show up in the repository, even though they have been created in the dm1 file and the EDD has been checked in to the repository.

  • Hi,

    In Data Architect if you go to Repository -> Data Dictionary -> Enterprise Data Dictionary Bindings, do you see the Enterprise Data Dictionary there? If you expand your EDD, do you see the objects there?

    If yes then the next question would be did you publish the model that contained the EDD in Team Server?

    If not, can you attach a screen print of the EDD in Data Architect or the model with the EDD?

    Thanks,
    Stan
  • In reply to Stanley Chan:

    Stan,

    Thanks for the reply. I do see the objects in the bindings dialog and I have published the model in Team Server. I have attached a screen shot of the bindings dialog window, as well as a screenshot of what appears (or doesn't appear) in Team Server.