DM1ComparisonManager encountering inconsistencies

I'm running ER Studio Data Architect 16.5.0 with Team Server Version 16.5 I am  having problems with DM1ComparisonManager encountering inconsistencies   and refusing to save/check in a diagram,

I get the following error:

If I try to clean the active file folder and try to checkout it gives me:

Repository operation failed. Cannot create GET_LATEST request.
00:00:00.031 - Total time for the whole process.

Anybody else out there having the same issue? I have a support ticket open for a week but no solution insight. Do we need to go back to older version.....?? Any help from the forum guru's will be appreciated

  • Hi,

    Couple of things.
    1) Where is the active file folder? Is on the local machine or a network shared?
    2) Does this happen with all models or just a single one?
    3) It looks like you tried to move the file out of the active file folder and tried to get a clean copy from the repo and it's giving you errors? Just wanted to confirm because if that's the case then there looks to be an issue with the model in the repository.

    Some things to try.
    1) Try changing the active file folder (repository -> Options). There could be a permissions issue with the folder for some reason.
    2) If you can get a fresh copy of the file then run a compare and merge and submodel sync to merge the changes from the old file to the fresh copy.
    If you tried 1 and it still doesn't work then this could be an issue with something in the database and you'd have to send a backup of your database to support so that they can figure out what's wrong there.

    Regards,
    Stan
  • In reply to Stanley Chan:

    Thanks for your reply.
    1) Where is the active file folder? Is on the local machine or a network shared? - Local folder
    2) Does this happen with all models or just a single one? Happening with existing as well as brand new model with single column on it
    3) It looks like you tried to move the file out of the active file folder and tried to get a clean copy from the repo and it's giving you errors? Just wanted to confirm because if that's the case then there looks to be an issue with the model in the repository. - That's the reason I tested with a brand new simple model with just 1 column. Gave the same reason.

    I am thinking it might be a database issue. The support ticket # is: 00583282

    Someday I might bug you with some macro's question :-)

    Thanks

    Jay
  • In reply to jaycha2:

    I get this error when I choose the option of "GET THE LATEST VERSION" from the repository
    CRepoClient::GetLatestVersion() failed. <-- CTransactionManager::GetLatestDiagram() failed. <-- CTransactionManager::DoDDTransaction() failed because CDm1SRTFManager::Transfer() failed.
  • Did you get this resolved? We are having the same issue.
  • In reply to maverick976:

    Not yet...waiting on a patch from IDERA. We are using sharepoint at this moment to get around this issue.