Team Server - Publishing Models from the Repository to Team Server and Team Server Synchronising with Repository

I'm having some issues understanding how to maintain the ER/Studio Publications list in Team Server and how to sync changes in the Repository with Team Server.

1. When viewing Sub Models in the Team Server site.  I get the error "The object may be deleted or not synchronised yet. The detailed report information is not available for this object at the current time.".  I seem to be able to see the details of all other kinds of objects except Sub Models, I can see the list of Sub Models but I get this error when I click on them

 

2. Prior to this issue, I wasn't seeing the latest version of the checked-in Model in the ER/Studio Team Server site.  Should the models synchronise in the background when checked-in or does this need to be triggered and how?

 

3. How do I update the List of Models in the ER/Studio Publications screen.  ER/Studio Publications only gives the action "Remove" for my Published models - I can sync them.  If I remove the drop off the list and I can't see how to add them back into the list.  Do I need to remove the add them from the Repository Project in Data Architect and then to get them to reappear in the list.  

  • Hi,

    For 1) and 3) I would recommend opening up a support case for those. I think there are some issues that need to be addressed. 3) is a known issue but support should have a fix for this.

    2) I think is related to 1) as it should update automatically once you've published a model. Anytime you check in a model the publication piece should kick off and update the model in Team Server.

    Overall, I would recommend contacting support to figure out what is happening.

    Regards,
    Stan
  • In reply to Stanley Chan:

    Our site is experiencing similar issues. Have been working with support for a couple months now. Have been informed that development is working on a fix.