Safe Agent installation problems

I am attempting to install the agent on a Windows 2016 x64 server, and get this error "Product: Idera SQLsafe Backup Service -- Idera SQLsafe Backup Service requires that your computer has the .NET Framework version 2.0 or higher installed."

 

Do I need to enable the .NET 3.5 Feature on this server?


SQL Safe 8.3.0.419